net-libs / webkit-gtk

Open source web browser engine

Official package sites : https://www.webkitgtk.org ·

v2.26.4-r1 :: 4/37 :: gentoo

Modified
License
LGPL-2+ BSD
Keywords
~amd64 ~arm64 ~ia64 ~ppc64 ~sparc ~x86
USE flags
X aqua coverage egl geolocation gles2-only gnome-keyring gstreamer gtk-doc introspection jpeg2k jumbo-build libnotify opengl seccomp spell test wayland

v2.26.4 :: 4/37 :: gentoo

Modified
License
LGPL-2+ BSD
Keywords
amd64 arm64 x86 ~ia64 ~ppc64 ~sparc
USE flags
X aqua coverage egl geolocation gles2-only gnome-keyring gstreamer gtk-doc introspection jpeg2k jumbo-build libnotify opengl seccomp spell test wayland

v2.24.4 :: 4/37 :: gentoo

Modified
License
LGPL-2+ BSD
Keywords
~alpha ~amd64-linux ~arm ~ppc ~x86-linux ~x86-macos
USE flags
X aqua coverage doc egl geolocation gles2 gnome-keyring gstreamer introspection jpeg2k libnotify nsplugin opengl spell test wayland webgl

General

X
Add support for X11
aqua
Include support for the Mac OS X Aqua (Carbon/Cocoa) GUI
coverage
Enable code coverage support
doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
egl
Enable EGL support
geolocation
Enable geolocation support through app-misc/geoclue
gles2
Enable GLESv2 support
gles2-only
Use GLES 2.0 or later instead of full OpenGL
gnome-keyring
Enable support for storing passwords via gnome-keyring
gstreamer
Add support for media-libs/gstreamer (Streaming media)
gtk-doc
Build and install gtk-doc based developer documentation for dev-util/devhelp, IDE and offline use
introspection
Add support for GObject based introspection
jpeg2k
Support for JPEG 2000, a wavelet-based image compression format
jumbo-build
Combine source files to speed up build process
libnotify
Enable desktop notification support
nsplugin
Enable full nsplugin support (GTK2 plugins)
opengl
Add support for OpenGL (3D graphics)
seccomp
Enable seccomp (secure computing mode) to perform system call filtering at runtime to increase security of programs
spell
Add dictionary support
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)
wayland
Enable dev-libs/wayland backend
webgl
Build support for the WebGL HTML API using virtual/opengl

app-accessibility / at-spi2-core : D-Bus accessibility specifications and registration daemon

app-arch / xz-utils : utils for managing LZMA compressed files

app-crypt / libsecret : GObject library for accessing the freedesktop.org Secret Service API

app-misc / geoclue : A location information D-Bus service

app-portage / elt-patches : Collection of patches for libtool.eclass

app-text / enchant : Spellchecker wrapping library

dev-db / sqlite : SQL database engine

dev-lang / perl : Larry Wall's Practical Extraction and Report Language

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / ruby : An object-oriented scripting language

dev-libs / atk : GTK+ & GNOME Accessibility Toolkit

dev-libs / glib : The GLib library of C routines

dev-libs / gobject-introspection : Introspection system for GObject-based libraries

dev-libs / hyphen : ALTLinux hyphenation library

dev-libs / icu : International Components for Unicode

dev-libs / libgcrypt : General purpose crypto library based on the code used in GnuPG

dev-libs / libtasn1 : ASN.1 library

dev-libs / libxml2 : XML C parser and toolkit

dev-libs / libxslt : XSLT libraries and tools

dev-util / cmake : Cross platform Make

dev-util / desktop-file-utils : Command line utilities to work with desktop menu entries

dev-util / gdbus-codegen : GDBus code and documentation generator

dev-util / glib-utils : Build utilities for GLib using projects

dev-util / gperf : A perfect hash function generator

dev-util / gtk-doc : GTK+ Documentation Generator

dev-util / gtk-doc-am : Automake files from gtk-doc

dev-util / ninja : A small build system similar to make

gui-libs / libwpe : Platform-agnostic interfaces for WPE WebKit

gui-libs / wpebackend-fdo : WPE backend designed for Linux desktop systems

media-libs / fontconfig : A library for configuring and customizing font access

media-libs / freetype : A high-quality and portable font engine

media-libs / gst-plugins-bad : Less plugins for GStreamer

media-libs / gst-plugins-base : Basepack of plugins for gstreamer

media-libs / gstreamer : Open source multimedia framework

media-libs / harfbuzz : An OpenType text shaping engine

media-libs / libpng : Portable Network Graphics library

media-libs / libwebp : A lossy image compression format

media-libs / mesa : OpenGL-like graphic library for Linux

media-libs / openjpeg : Open-source JPEG 2000 library

media-libs / woff2 : Encode/decode WOFF2 font format

media-plugins / gst-plugins-opus : Opus audio parser plugin for GStreamer

net-libs / libsoup : HTTP client/server library for GNOME

sys-apps / bubblewrap : Unprivileged sandboxing tool, namespaces-powered chroot-like solution

sys-apps / xdg-dbus-proxy : Filtering proxy for D-Bus connections

sys-devel / bison : A general-purpose (yacc-compatible) parser generator

sys-devel / clang : C language family frontend for LLVM

sys-devel / gcc : The GNU Compiler Collection

sys-devel / gettext : GNU locale utilities

sys-libs / libseccomp : high level interface to Linux seccomp filter

sys-libs / zlib : Standard (de)compression library

virtual / jpeg : Virtual to select between libjpeg-turbo and IJG jpeg for source-based packages

virtual / opengl : Virtual for OpenGL implementation

virtual / perl-Carp : Virtual for Carp

virtual / perl-Data-Dumper : Virtual for Data-Dumper

virtual / perl-JSON-PP : Virtual for JSON-PP

virtual / pkgconfig : Virtual for the pkg-config implementation

virtual / rubygems : Virtual ebuild for rubygems

x11-apps / xhost : Controls host and/or user access to a running X server

x11-base / xorg-server : X.Org X servers

x11-libs / cairo : A vector graphics library with cross-device output support

x11-libs / gtk+ : Gimp ToolKit +

x11-libs / libX11 : X.Org X11 library

x11-libs / libXcomposite : X.Org Xcomposite library

x11-libs / libXdamage : X.Org Xdamage library

x11-libs / libXrender : X.Org Xrender library

x11-libs / libXt : X.Org X Toolkit Intrinsics library

x11-libs / libnotify : A library for sending desktop notifications

x11-misc / shared-mime-info : The Shared MIME-info Database specification

app-crypt / libsecret : GObject library for accessing the freedesktop.org Secret Service API

app-misc / geoclue : A location information D-Bus service

app-text / enchant : Spellchecker wrapping library

dev-db / sqlite : SQL database engine

dev-libs / atk : GTK+ & GNOME Accessibility Toolkit

dev-libs / glib : The GLib library of C routines

dev-libs / gobject-introspection : Introspection system for GObject-based libraries

dev-libs / hyphen : ALTLinux hyphenation library

dev-libs / icu : International Components for Unicode

dev-libs / libgcrypt : General purpose crypto library based on the code used in GnuPG

dev-libs / libtasn1 : ASN.1 library

dev-libs / libxml2 : XML C parser and toolkit

dev-libs / libxslt : XSLT libraries and tools

gui-libs / libwpe : Platform-agnostic interfaces for WPE WebKit

gui-libs / wpebackend-fdo : WPE backend designed for Linux desktop systems

media-libs / fontconfig : A library for configuring and customizing font access

media-libs / freetype : A high-quality and portable font engine

media-libs / gst-plugins-bad : Less plugins for GStreamer

media-libs / gst-plugins-base : Basepack of plugins for gstreamer

media-libs / gstreamer : Open source multimedia framework

media-libs / harfbuzz : An OpenType text shaping engine

media-libs / libpng : Portable Network Graphics library

media-libs / libwebp : A lossy image compression format

media-libs / mesa : OpenGL-like graphic library for Linux

media-libs / openjpeg : Open-source JPEG 2000 library

media-libs / woff2 : Encode/decode WOFF2 font format

media-plugins / gst-plugins-opus : Opus audio parser plugin for GStreamer

net-libs / libsoup : HTTP client/server library for GNOME

sys-apps / bubblewrap : Unprivileged sandboxing tool, namespaces-powered chroot-like solution

sys-apps / xdg-dbus-proxy : Filtering proxy for D-Bus connections

sys-libs / libseccomp : high level interface to Linux seccomp filter

sys-libs / zlib : Standard (de)compression library

virtual / jpeg : Virtual to select between libjpeg-turbo and IJG jpeg for source-based packages

virtual / opengl : Virtual for OpenGL implementation

x11-libs / cairo : A vector graphics library with cross-device output support

x11-libs / gtk+ : Gimp ToolKit +

x11-libs / libX11 : X.Org X11 library

x11-libs / libXcomposite : X.Org Xcomposite library

x11-libs / libXdamage : X.Org Xdamage library

x11-libs / libXrender : X.Org Xrender library

x11-libs / libXt : X.Org X Toolkit Intrinsics library

x11-libs / libnotify : A library for sending desktop notifications

app-editors / emacs : The extensible, customizable, self-documenting real-time display editor

app-misc / bijiben : Note editor designed to remain simple to use

app-office / gnucash : A personal finance manager

app-text / atril : Atril document viewer for MATE

app-text / libgepub : GObject based library for handling and rendering epub documents

app-text / xiphos : A bible study frontend for Sword (formerly known as GnomeSword)

dev-java / swt : GTK based SWT Library

dev-ruby / ruby-webkit2-gtk : Ruby WebKitGtk+ for Gtk 3.0 bindings

dev-util / devhelp : An API documentation browser for GNOME

dev-util / geany-plugins : A collection of different plugins for Geany

dev-util / glade : A user interface designer for GTK+ and GNOME

dev-util / gnome-builder : An IDE for writing GNOME-based software

games-util / lutris : An open source gaming platform for GNU/Linux

gnome-extra / cinnamon-screensaver : Screensaver for Cinnamon

gnome-extra / evolution-data-server : Evolution groupware backend

gnome-extra / gnome-boxes : Simple GNOME 3 application to access remote or virtual systems

gnome-extra / gnome-documents : A document manager application for GNOME

gnome-extra / sushi : A quick previewer for Nautilus, the GNOME file manager

gnome-extra / yelp : Help browser for GNOME

gnome-extra / zenity : Tool to display dialogs from the commandline and shell scripts

mail-client / balsa : Email client for GNOME

mail-client / evolution : Integrated mail, addressbook and calendaring functionality

mail-client / geary : A lightweight, easy-to-use, feature-rich email client

media-gfx / birdfont : Font editor for the creation of vector graphics and export TTF, EOT & SVG fonts

media-gfx / gthumb : Image viewer and browser for Gnome

media-gfx / shotwell : Open source photo manager for GNOME

net-im / empathy : Telepathy instant messaging and video/audio call client for GNOME

net-libs / gnome-online-accounts : GNOME framework for accessing online accounts

net-libs / libproxy : Library for automatic proxy configuration management

net-mail / mu : Set of tools to deal with Maildirs, in particular, searching and indexing

net-misc / icaclient : ICA Client for Citrix Presentation servers

net-misc / remmina : A GTK+ RDP, SPICE, VNC, XDMCP and SSH client

net-news / liferea : News Aggregator for RDF/RSS/CDF/Atom/Echo feeds

sci-geosciences / gnome-maps : A map application for GNOME

www-client / epiphany : GNOME webbrowser based on Webkit

www-client / luakit : A fast, light, simple to use micro-browser using WebKit and Lua

www-client / midori : A lightweight web browser based on WebKitGTK+

www-client / surf : a simple web browser based on WebKit/GTK+

x11-libs / wxGTK : GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit

526998
net-libs/webkit-gtk: requesting a binary package
533622
net-libs/webkit-gtk-2.6.4 gtkdoc-scan: Traceback (most recent call last): File "/home/gentoo/build/portage/net-libs/webkit-gtk-2.6.4/work/webkitgtk-2.6.4/Tools/gtk/generate-gtkdoc", line 201, OSError: [Errno 2] No such file or directory
617674
net-libs/webkit-gtk-2.16.1: multiple browsers fail at opening any website (was: www-client/midori-0.5.11-r2)
640338
net-libs/webkit-gtk-2.18.3 LTO patch found
641398
net-libs/webkit-gtk-2.18.3 fails to compile with no -O? optimization in CXXFLAGS (on purpose from upstream)
646034
net-libs/webkit-gtk-2.18.6 needs CHECKREQS_DISK_BUILD increasing beyond 20G
649388
net-libs/webkit-gtk: seems to ignore MAKEOPTS
670372
>=net-libs/webkit-gtk-2.24.1 USE=gstreamer - Source/WebKit/CMakeFiles/WebKit.dir/__/__/DerivedSources/WebKit/AutomationBackendDispatchers.cpp.o:AutomationBackendDispatchers.cpp: function ...(): error: relocation overflow
672492
net-libs/webkit-gtk - cross-compiling from x86_64 to i686 - CalleeBits.h:54:81: error: 'TagBitsWasm' was not declared in this scope
680382
net-libs/webkit-gtk-2.24.0 - In file included from .../work/webkitgtk-2.24.0/Source/JavaScriptCore/API/JSValueRef.cpp:30: .../work/webkitgtk-2.24.0/Source/JavaScriptCore/API/APIUtils.h:60:5: error: 'VM' was not declared in this scope
684682
net-libs/webkit-gtk-2.24.1 - .../work/webkitgtk-2.24.1/Source/JavaScriptCore/assembler/ARM64Assembler.h:3769:100: error: ‘class JSC::AssemblerBuffer’ has no member named ‘data’ on machines with Cortex-A53 CPU
685940
net-libs/webkit-gtk-2.24.1 - /usr/bin/ruby24 .../work/webkitgtk-2.24.1/Source/JavaScriptCore/offlineasm/generate_offset_extractor.rb .../work/webkit-gtk-2.24.1_build/DerivedSources/JavaScriptCore/LLIntDesiredOffsets.h ARM64: FAILED: ...
689738
net-libs/webkit-gtk-2.24.3 : -- Performing Test C_COMPILER_SUPPORTS_-Qunused-arguments - Failed
704182
>=net-libs/webkit-gtk-2.26.2 re-keywording
704550
net-libs/webkit-gtk-2.26.2 - src_compile(): Exception: gtkdoc-mkhtml produced a non-zero return code 6
705264
=net-libs/webkit-gtk-2.24.4 uses lexicographical version compare
708426
net-libs/webkit-gtk-2.26.3 with sys-libs/musl : .../work/webkitgtk-2.26.3/Source/JavaScriptCore/runtime/SamplingProfiler.cpp:379:48: error: ‘framePointer’ is not a member of ‘JSC::MachineContext’
712260
net-libs/webkit-gtk: Denial of service issue in accessibility/AXObjectCache.cpp (CVE-2020-10018/WSA-2020-0003)
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup to the extent possible
Vulnerable versions only in ~arch versions now due to lack of movement on many architectures on re-keywording Bug: https://bugs.gentoo.org/709612 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: arm64 stable (bug #709612)
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: arm64 keyworded (bug #704182)
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Bug: https://bugs.gentoo.org/709612 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #709612)
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #709612
Package-Manager: Portage-2.3.84, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.26.4
-r0 is for fast security stabling, -r1 is the enchant:2 ensuring revision. Bug: https://bugs.gentoo.org/709612 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
net-libs/webkit-gtk: Remove py2 where possible
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: ensure enchant:2 gets used
We need a revision that ensures enchant:2 gets used, so that other packages can also ensure all components use enchant:2 (e.g. geary pulls in enchant itself, via gspell and via webkit-gtk), so they don't mix them all into the same process space, ending up with the potential for mystery issues due to symbol mixing. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #706374
Package-Manager: Portage-2.3.84, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Piotr Karbowski · gentoo
net-libs/webkit-gtk-2.26.3: amd64 stable (bug 706374)
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.26.3, fix gtk-doc
Move gtk-doc building from USE=doc to USE=gtk-doc, as the latter is the one to use now for when generating gtk-doc from scratch. Fix it with perl-based gtk-doc by stripping out some tags in the docs completely; this was already fixed upstream, but that fix seems dependent on newer gtk-doc handling the markdown quoting that got added. So remove the tags completely until we can depend on a newer gtk-doc that doesn't have trouble with the upstream way. Also a build fix for USE="wayland -opengl -gles2-only" (but remember: you shouldn't disable both opengl and gles2-only on any real desktop system). Bug: https://bugs.gentoo.org/706374 Bug: https://bugs.gentoo.org/704550 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Rolf Eike Beer · gentoo
net-libs/webkit-gtk: keyworded 2.26.2 for sparc, bug #704182
Package-Manager: Portage-2.3.84, Repoman-2.3.20 RepoMan-Options: --include-arches="sparc" Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: fix USE=-jumbo-build builds on non-amd64
In some non-amd64 architectures (arm and sparc at least), there are missing headers in JSC. Not sure what the trigger is - maybe lack of FTL, or some other differences. Hopefully fix it by patching in the necessary includes to the places I could identify with limited armv7a cross-compiling. Closes: https://bugs.gentoo.org/704194 Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: fix ruby check for cross-compilation
Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sergei Trofimovich · gentoo
net-libs/webkit-gtk: keyworded 2.26.2 for ppc64, bug #704182
Package-Manager: Portage-2.3.84, Repoman-2.3.20 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Sergei Trofimovich · gentoo
net-libs/webkit-gtk: keyworded 2.26.2 for ia64, bug #704182
Package-Manager: Portage-2.3.84, Repoman-2.3.20 RepoMan-Options: --include-arches="ia64" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #699156)
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: Unconditionally build WebGL with enabled OpenGL
Building with ENABLE_GL but without WEBGL is unsupported upstream and has no real benefits. The WebGL support can be disabled at runtime, if desired. Therefore tie the choice of WebGL support to having enabled GL support (full opengl or gles2), matching what upstream does if an explicit ENABLE_WEBGL _private_ configuration value isn't given. We keep it as a separately passed arg for now just for the sake of being explicit. WebGL has been fine without gstreamer for a while now - that seems to have been a temporary bug in the ancient 2.10 series - so all this does not mean that gstreamer is required with GL and the REQUIRED_USE that was there is dropped (not only due to IUSE=webgl going away - had it stayed, the restriction was wrong with USE=webgl being there too). It should also be fine without libXcomposite and libXdamage on wayland-only builds, so those deps are simply dropped (they are still there for USE=X). This may have been a reason some may have wanted to disable WebGL for wayland-only builds, but it was probably legacy wrong deps. Update a comment about WebRTC (upstream is using libwebrtc instead of OpenWebRTC right now, but isn't a supported build option out of tarballs, plus it may end up using gstreamer instead before it becomes non-experimental). Also remove outdated comment about FTL_JIT (it doesn't need llvm anymore and we are letting it be handled automatically by upstream cmake per-architecture conditionals). Drop -fno-strict-aliasing build flags forcing - upstream build system is supposed to take care of it these days. As I confirmed I still get it in the compiler calls, this change does not necessitate a revbump either (the rest are --changed-use territory). Closes: https://bugs.gentoo.org/704538 Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk-2.26: fix unsupported no-GL build
Closes: https://bugs.gentoo.org/704236 Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #699156
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: adjust compiler deps and checks
The gcc < 7.3 check will work wrong once gcc10 comes along. Adjust the clang dep to match when initial C++17 support came along. Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.26.2
* Add unconditional sandboxing support, if available for the arch. * Switch IUSE=gles2 to IUSE=gles2-only, as it is an alternative to USE=opengl, not a co-existing one. * USE=wayland now requires wpebackend-fdo and co for accelerated compositing under wayland, if opengl is enabled. * Re-enable IUSE=+jumbo-build for unified source builds - it was unconditionally enabled before, but with 2.26 disabling it finally seems to work. Disabling it seems to result in a 2MB larger library and over twice the compile time, but it may be crucial to low RAM systems to be able to even build webkit-gtk at all. * gtk2 plugin process is now dropped upstream - no more adobe-flash support. * geoclue is a runtime-only depend now (dbus interface). * GCC/clang checks updated to the best of my understanding. * Added ruby:2.7 support for the build-time depend on it. Bug: https://bugs.gentoo.org/699156 Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: add upstream bug reference to glvnd patch
Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
net-libs/webkit-gtk: Add patch to build with mesa-19.3
Thanks to Alexander Tsoy for the patch. Closes: https://bugs.gentoo.org/699054 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/webkit-gtk: Add upstream patch to fix build against ICU-65
https://bugs.webkit.org/show_bug.cgi?id=202600 Acked-by: Mart Raudsepp <leio@gentoo.org> Closes: https://bugs.gentoo.org/698596 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
net-libs: Remove *-fbsd KEYWORDS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Bug: https://bugs.gentoo.org/693122 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #693122
Package-Manager: Portage-2.3.69, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #693122
Package-Manager: Portage-2.3.69, Repoman-2.3.16 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
net-libs/webkit-gtk: arm64 stable (bug #693122)
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.74, Repoman-2.3.17 RepoMan-Options: --include-arches="arm64"
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.24.4
Bug: https://bugs.gentoo.org/693122 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: remove old
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #692356
Package-Manager: Portage-2.3.69, Repoman-2.3.16 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #692356
Package-Manager: Portage-2.3.69, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
net-libs/webkit-gtk: arm64 stable (bug #692356)
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.71, Repoman-2.3.17 RepoMan-Options: --include-arches="arm64"
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.24.3
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: default enable jpeg2k
JPEG 2000 support is important for various image managers on the web, because they are giving that format with the currently used User Agent, while they'd give WebP with different user agents. But using that different UA would break many other things, thus jpeg2k is pretty much mandatory for good browser usages, therefore default enable it at least. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
net-libs/webkit-gtk: arm64 stable
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #686216
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #686216)
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.24.2
Hopefully handles SSE2 missing from CXXFLAGS better. Unknown what happens for machines that are actually without SSE2 runtime support. Closes: https://bugs.gentoo.org/684540 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Bug: https://bugs.gentoo.org/683234 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #683234)
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #683234
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.24.1, drop JIT control
JIT manual control is getting complicated for limited benefits, which mostly involve oneself shooting in the foot. Let upstream build system figure out whether it should do JIT or not and don't get in the way. May be revisited based on any fallout and relevant bug reports after discussions on such reports convince it's needed. Bug: https://bugs.gentoo.org/683234 Bug: https://bugs.gentoo.org/680580 Bug: https://bugs.gentoo.org/680464 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: add support for building with ruby:2.6
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: remove redundant double deps
Closes: https://bugs.gentoo.org/680620 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: non-unified build option doesn't work; remove
USE=-jumbo-build fails to build; remove the option for now if it fails anyways. Bug: https://bugs.gentoo.org/680382 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.24.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.22.7
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #678334
Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #678334)
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.22.6
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: require GL
non-GL builds are only meant for some rare use case needs in the embedded world. But they are still broken a bit, so just disallow them for now again. Saves time for those that are for some reason still trying to disable GL fully. Bug: https://bugs.gentoo.org/666806 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #672108
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #672108)
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.22.5
Allow building without opengl again, as the bugs are fixed, but this is a very bad idea to do, so added a fat warning if done. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: sec bump to 2.22.4; require GL
* Security bump to 2.22.4 for WSA-2018-0008 * Builds without GL (opengl or gles2) are currently broken, thus REQUIRED_USE it. * Stop requiring gstreamer for introspection - seems to work fine without by now. * GstreamerGL requires EGL, so REQUIRED_USE it by requiring EGL if USE="gstreamer opengl" (USE="gstreamer gles2" is already covered by gles2 itself also requiring egl). * Raise gstreamer deps to ensure working MSE, as hopefully we can handle the stabilization of newer gst-plugins-opus for this security stabilization round. * Add references to upstream bugs above REQUIRED_USE - we should monitor them on bumps to relax the requirements when/if the upstream bugs are fixed. Closes: https://bugs.gentoo.org/671002 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: add gst-plugins-opus dependency for MSE
MSE needs opus, though techically this is optional. Pull it in with USE=gstreamer always for now, to trigger the opusparse related blocker in epiphany for now, while not actually depending on new enough gst-plugins-opus here, as we are ahead in keywords for webkit due to security. Later this dep should be removed again (once gst-plugins-opus with opusparse is stable) or the dep raised to 1.14.4-r1. Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Bug: https://bugs.gentoo.org/667892 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #667892
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #667892)
Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.22.2
Bug: https://bugs.gentoo.org/667892 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Bug: https://bugs.gentoo.org/658168 Package-Manager: Portage-2.3.46, Repoman-2.3.10
Mart Raudsepp · gentoo
net-libs/webkit-gtk: roll ~amd64-fbsd keyword forward for security
Add ~amd64-fbsd keyword to 2.20.5 as they have woff2 keyworded now. Remove ~amd64-fbsd keyword from 2.18.6 as it's security vulnerable. Package-Manager: Portage-2.3.46, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: roll ~alpha keyword forward
Add ~alpha keyword to 2.20.5 as they have woff2 keyworded now. Remove ~alpha keyword from 2.18.6 as it's security vulnerable. Package-Manager: Portage-2.3.46, Repoman-2.3.10
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.20.5 for a rendering regression fix
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: roll ~ppc keyword forward
Add ~ppc keyword to 2.20.4 as they have woff2 keyworded now. Remove ~ppc keyword from 2.18.6 as it's security vulnerable. Package-Manager: Portage-2.3.46, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #662974
Package-Manager: Portage-2.3.40, Repoman-2.3.9 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #662974)
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.20.4
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: roll ~ppc64 keyword forward
Add ~ppc64 keyword to 2.20.3 as they have woff2 keyworded now. Remove ~ppc64 keyword from 2.18.6 as it's security vulnerable. Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: partial security cleanup
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #652820
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk-2.20.3: restore ~ia64 keyword
media-libs/woff2 received ~ia64 keyword, so bring it back here as well. Hopefully someone actually builds the upgrade and sees if things still work after the WTF_CPU_IA64 patch drop (as "unknown CPU" error was removed upstream). Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #652820)
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk: fix non-parallel builds
Parallel builds might have failed too before this patch, but had to be very "lucky". Closes: https://bugs.gentoo.org/662002 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk-2.20.3: restore ~prefix and ~arm64 keywords
They have woff2 keyworded now. prefix has other issues in a big set of profiles, but this dropping was about woff2, so just restore them still and let them deal with it when anyone notices. Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
net-libs/webkit-gtk-2.20.3: restore ~arm and ~sparc keywords
They've keyworded media-libs/woff2 since the start of work on webkit-gtk bump. Package-Manager: Portage-2.3.43, Repoman-2.3.10
Mart Raudsepp · gentoo
net-libs/webkit-gtk: comment out unused test deps
Tests are restricted anyways, so hide the extra deps from repoman and co Package-Manager: Portage-2.3.43, Repoman-2.3.10
Mart Raudsepp · gentoo
net-libs/webkit-gtk-2.20.3: disable experimental accelerated 2D canvas
ACCELERATED_2D_CANVAS is considered experimental by upstream. I'm not sure what the justification was for enabling it with USE="webgl opengl" for us. The only reason this code isn't removed fully from upstream is because it _MIGHT_ be useful for some embedded use cases, yet it doesn't work with GLES2 yet, only desktop opengl. Additionally, for us this is causing additional cairo[opengl] dependency that can't be avoided for just non-experimental WebGL support via desktop GL as it was setup before in ebuild. No-one but Gentoo is building with this experimental option (not even upstream developers), and any issues about it won't really be cared about. Disable it and drop the cairo[opengl] dependency. https://lists.webkit.org/pipermail/webkit-gtk/2017-March/002969.html https://lists.webkit.org/pipermail/webkit-gtk/2017-April/003004.html If this is ever added back for any reason, make sure cairo[opengl] isn't depended on when not necessary (when accelerated 2d canvas is disabled, e.g. previously USE="opengl gles2" pulled in cairo[opengl] still, albeit that combination was not allowed previously, but a future webkit-gtk upstream version may support them together) and review if cairo-glesv2 is supported (and so it'd be supported with USE=gles2 too, unlike now). Bug: https://bugs.gentoo.org/581248 Closes: https://bugs.gentoo.org/643726 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Mart Raudsepp · gentoo
net-libs/webkit-gtk: remove unused versionator and eutils inherits
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Mart Raudsepp · gentoo
net-libs/webkit-gtk-2.20.3: add missing new perl JSON::PP build dep
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Mart Raudsepp · gentoo
net-libs/webkit-gtk: simplify opengl vs gles2 handling, fix gst gles2 deps
webkit-gtk itself does not support both full OpenGL and GLESv2 at once yet. ENABLE_OPENGL enables OpenGL in general, and if enabled then ENABLE_GLES2 determines which API is used - if enabled, then gles2, otherwise full GL. Simplify REQUIRED_USE handling to enforce the opengl/gles2 conflict separately, and have the webgl case just want either, to be future-proof and easier to read independently. WebGL should just always be enabled when either GL API is enabled, but keeping it under USE flag for the time being, until an even deeper GL/GStreamer webkitgtk cmake review, due to the webgl? ( gstreamer ) REQUIRED_USE still present. For now just (probably) properly depend on gstreamer gles2 support for USE="gles2 gstreamer" builds. Bug: https://bugs.gentoo.org/500150 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Virgil Dupras · gentoo
net-libs/webkit-gtk: add support for ruby25
Also, improve ruby interpreter detection logic. Closes: https://bugs.gentoo.org/659130 Bug: https://bugs.gentoo.org/513888 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Virgil Dupras · gentoo
net-libs/webkit-gtk: bump to 2.20.3
* New dependency on media-libs/woff2 require us to drop keywords * Drop redundant python dependency under tests * The ia64 patch is no longer needed: the fatal build error on unknown CPUs has been removed. * arm64 compilation is fixed upstream. Closes: https://bugs.gentoo.org/655550 Closes: https://bugs.gentoo.org/644284 Closes: https://github.com/gentoo/gentoo/pull/9271 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Michael Mair-Keimberger · gentoo
net-libs/webkit-gtk: use HTTPS
Mart Raudsepp · gentoo
net-libs/webkit-gtk: Remove security vulnerable SLOT=2 and SLOT=3
These slots are years old, unmaintained and vulnerable to hundreds of bugs with a CVE assigned. Additionally there are some known unfixed issues building against newer ICU. No interest in continued maintenance of known hugely security vulnerable versions, thus with no consumers remaining in main tree, this is going away now. Sorry. If you need this, please think seriously ten times before you make it available to yourself via an overlay, or use any software that requires this security riddled version still. Closes: https://bugs.gentoo.org/577068
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
https://bugs.gentoo.org/645686 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mikle Kolyada · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #645686
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #645686)
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Mart Raudsepp · gentoo
net-libs/webkit-gtk: default enable USE=X in preparation of use.force removal
Bug: https://bugs.gentoo.org/643724 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.18.6
Bug: https://bugs.gentoo.org/645686 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Bug: https://bugs.gentoo.org/644128 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #644128
Package-Manager: Portage-2.3.13, Repoman-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #644128)
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.18.5 for Spectre mitigation
Bug: https://bugs.gentoo.org/644128 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Bug: https://bugs.gentoo.org/641752 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #641752
Package-Manager: Portage-2.3.13, Repoman-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #641752)
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security bump to 2.18.4
Bug: https://bugs.gentoo.org/641752 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Manuel Rüger · gentoo
net-libs/webkit-gtk: Remove vulnerable 2.18.2 as requested by leio
Bug: https://bugs.gentoo.org/637076 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #637076)
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #637076
Package-Manager: Portage-2.3.13, Repoman-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Ian Stakenvicius · gentoo
net-libs/webkit-gtk: bump to 2.18.3 for security
Bug: https://bugs.gentoo.org/637076 Acked-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.13, Repoman-2.3.3
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Bug: https://bugs.gentoo.org/635134 Package-Manager: Portage-2.3.8, Repoman-2.3.2
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #635134)
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #635134
Package-Manager: Portage-2.3.8, Repoman-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.18.2
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Mart Raudsepp · gentoo
net-libs/webkit-gtk: USE=gstreamer,egl requires gst-plugins-bad[egl] now
If EGL is enabled, then the gstreamer code (only compiled with USE=gstreamer) will want to include gstreamer egl headers, in addition to gst gl headers Bug: https://bugs.gentoo.org/635144 Package-Manager: Portage-2.3.8, Repoman-2.3.2
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.18.1 for security; other package touchups
- reorder deps to cmake checks order - add missing zlib dep - move gtk platform USE checks to the main depstring, as that's requiring newer version anyway - remove unnecessary pango dep (not checked in cmake, minimal usage comes via gtk+ deps) - add WebCrypto deps, without giving optionality (it's a private option) - add missing cmake-utils_src_prepare call - remove ancient <glibc-2.18 code - fix jsc pax-mark - remove ruby21 support (gone from tree and repoman warning about the slot) - GL deps and conditions remain a mystery to me for now Closes: https://bugs.gentoo.org/626736 Package-Manager: Portage-2.3.8, Repoman-2.3.2
Gilles Dartiguelongue · gentoo
net-libs/webkit-gtk: cleanup security vulnerable 2.16.5, bug #626142
Bug: https://bugs.gentoo.org/show_bug.cgi?id=626142 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Thomas Deutschmann · gentoo
net-libs/webkit-gtk: x86 stable (bug #626142)
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Tobias Klausmann · gentoo
net-libs/webkit-gtk-2.16.6-r0: amd64 stable
Gentoo-Bug: 626142
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.16.6 for security fixes
Fixes CVE-2017-7018, CVE-2017-7030, CVE-2017-7034, CVE-2017-7037, CVE-2017-7039, CVE-2017-7046, CVE-2017-7048, CVE-2017-7055, CVE-2017-7056, CVE-2017-7061 and CVE-2017-7064. Gentoo-bug: 626142 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Alexis Ballier · gentoo
net-libs/webkit-gtk: keyword ~arm64
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #622442
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #622442
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.16.5 for a crash and a wayland regression fix
Upstream changes: * Fix a web process crash when page finishes loading in several web sites. * Fix the menu of select elements not showing in some cases under Wayland. This is meant to be the security stabilization target for CVE-2017-2538 for a regression free upgrade Package-Manager: Portage-2.3.5, Repoman-2.3.2
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #622442
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.16.4 for bug fixes, including a security fix
Fixes CVE-2017-2538 among other bug fixes Package-Manager: Portage-2.3.5, Repoman-2.3.2
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Gentoo-bug: 619788 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #619788
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #619788
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.16.3; includes 3 security bug fixes
Security fixes: CVE-2017-2496, CVE-2017-2539, CVE-2017-2510. Also other bug fixes.
Mart Raudsepp · gentoo
net-libs/webkit-gtk: remove old
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #618420
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #618420
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.16.2 for various fixes, including new Google login page
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Mart Raudsepp · gentoo
net-libs/webkit-gtk: security cleanup
Gentoo-bug: 614876 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #614876
Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #614876
Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.16.1 for 33+ security fixes
Fixes CVE-2016-9642, CVE-2016-9643, CVE-2017-2367, CVE-2017-2376, CVE-2017-2377, CVE-2017-2386, CVE-2017-2392, CVE-2017-2394, CVE-2017-2395, CVE-2017-2396, CVE-2017-2405, CVE-2017-2415, CVE-2017-2419, CVE-2017-2433, CVE-2017-2442, CVE-2017-2445, CVE-2017-2446, CVE-2017-2447, CVE-2017-2454, CVE-2017-2455, CVE-2017-2457, CVE-2017-2459, CVE-2017-2460, CVE-2017-2464, CVE-2017-2465, CVE-2017-2466, CVE-2017-2468, CVE-2017-2469, CVE-2017-2470, CVE-2017-2471, CVE-2017-2475, CVE-2017-2476, CVE-2017-2481 and further fixes for CVE-2017-2364. Upstream says 2.16.1 fixes more security bugs than these, over 2.16.0 release, but that they didn't have CVE numbers as of yet. Add some seemingly necessary perl build dependencies (which everyone probably had installed anyways). This perl build dep list is by no means complete. Includes preliminary patch from Kent to not start requiring perl[ithreads] for building (over perl with whatever ithreads choice), which would be disastrous for us. Upstream has replaced gnutls with libgcrypt. The experimental API unstable DOM stuff was dropped completely (but isn't used since epiphany-3.22), while the webkit2gtkinjectedbundle-j1.patch patch in earlier version modified lines that were there for it - so hopefully -j1 MAKEOPTS building still works with that patch dropped. CREDENTIAL_STORAGE option was renamed to LIBSECRET. flex build dep seems to have been dropped and gstreamer requirement upped to 1.2.3. harfbuzz 1.3.3 is useful for it for some optional fixes, so guarantee it. Gentoo-bug: 614876 Thanks-to: Kent Fredric <kentnl@gentoo.org>
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: remove old (security cleanup)
Gentoo-bug: 608958 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #608958
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #608958
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
net-libs/webkit-gtk: bump to 2.14.5 for serious HiDPI regression fixes
* Fix rendering of non-accelerated contents with HiDPI. * Revert the fix for rendering issues in long documents with transparent background because it caused issues in HiDPI. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Pacho Ramos · gentoo
net-libs/webkit-gtk: amd64/x86 stable, bug #608958
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Pacho Ramos · gentoo
net-libs/webkit-gtk: Drop old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Pacho Ramos · gentoo
net-libs/webkit-gtk: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Fabian Groffen · gentoo
net-libs/webkit-gtk: dropped ~ia64-linux ~x86-freebsd
Package-Manager: portage-2.3.3
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Pacho Ramos · gentoo
net-libs/webkit-gtk: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Mart Raudsepp · gentoo
net-libs/webkit-gtk: Remove old
Package-Manager: portage-2.3.3
Christophe Lermytte · gentoo
net-libs/webkit-gtk: add webkit-gtk-2.14.2.ebuild
Simple bump from 2.14.1, no relevant changes when comparing 2.14.2 and 2.14.1 tarballs Closes: https://github.com/gentoo/gentoo/pull/2788 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Gilles Dartiguelongue · gentoo
net-libs/webkit-gtk: cleanup old revisions
Package-Manager: portage-2.3.2
Gilles Dartiguelongue · gentoo
net-libs/webkit-gtk: version bump 2.12.5 → 2.14.1
Package-Manager: portage-2.3.2
Pacho Ramos · gentoo
net-libs/webkit-gtk: x86 stable, bug 587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86"
Pacho Ramos · gentoo
net-libs/webkit-gtk: amd64 stable, bug 587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64"
Gilles Dartiguelongue · gentoo
net-libs/webkit-gtk: version bump 2.12.3 → 2.12.5
Package-Manager: portage-2.3.0
Gilles Dartiguelongue · gentoo
net-libs/webkit-gtk: raise gst-plugins-bad to 1.6
Per .cmake, needed for gst-plugins-gl. Package-Manager: portage-2.3.0
Sergei Trofimovich · gentoo
net-libs/webkit-gtk: tweak for gcc-6, bug #592048
Adopt Fedora patch to build successfully against gcc-6.1.0. Bug: https://bugs.gentoo.org/show_bug.cgi?id=592048 Bug: https://bugs.webkit.org/show_bug.cgi?id=159124 Package-Manager: portage-2.3.0
Pacho Ramos · gentoo
Rename geoloc to geolocation USE (#588168), ensure gtk+-3.20 is used to fix theming (https://bugzilla.gnome.org/show_bug.cgi?id=757503).
Package-Manager: portage-2.3.0
Pacho Ramos · gentoo
net-libs/webkit-gtk: ACCELERATED_2D_CANVAS is not compatible with gles2 (#588698 by skobk.in)
Package-Manager: portage-2.3.0
Pacho Ramos · gentoo
net-libs/webkit-gtk: Version bump
Package-Manager: portage-2.3.0_rc1
Pacho Ramos · gentoo
net-libs/webkit-gtk: Drop old
Package-Manager: portage-2.3.0_rc1
Pacho Ramos · gentoo
net-libs/webkit-gtk: x86 stable, bug 584468
Package-Manager: portage-2.3.0_rc1 RepoMan-Options: --include-arches="x86"
Pacho Ramos · gentoo
net-libs/webkit-gtk: amd64 stable, bug 584468
Package-Manager: portage-2.3.0_rc1 RepoMan-Options: --include-arches="amd64"
Tobias Klausmann · gentoo
net-libs/webkit-gtk-2.10.9-r0: add ~alpha keyword
Gentoo-Bug: 566270 Package-Manager: portage-2.3.0_rc1
Pacho Ramos · gentoo
net-libs/webkit-gtk: Fix virtualx.eclass usage
Package-Manager: portage-2.3.0_rc1
Pacho Ramos · gentoo
net-libs/webkit-gtk: Drop old
Package-Manager: portage-2.3.0_rc1
Pacho Ramos · gentoo
net-libs/webkit-gtk: Make repoman more happy
Package-Manager: portage-2.3.0_rc1
Pacho Ramos · gentoo
net-libs/webkit-gtk: Version bump
Package-Manager: portage-2.3.0_rc1
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #570034
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #577068
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #570034
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #577068
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Pacho Ramos · gentoo
net-libs/webkit-gtk: Version bump
Package-Manager: portage-2.2.28
Pacho Ramos · gentoo
net-libs/webkit-gtk: Drop old
Package-Manager: portage-2.2.28
Lars Wendler · gentoo
net-libs/webkit-gtk: Security bump to version 2.10.8 (bug #577068).
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/sbraz/syncthing'
Pull Request: https://github.com/gentoo/gentoo/pull/990
Mikle Kolyada · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #566378
Package-Manager: portage-2.2.26
Pacho Ramos · gentoo
net-libs/webkit-gtk: amd64 stable, bug 566378
Package-Manager: portage-2.2.27 RepoMan-Options: --include-arches="amd64"
James Le Cuirot · gentoo
net-libs/webkit-gtk: Allow Ruby 2.3 when building 2.4.9 wrt #573714
No revbump because it's a build time only change and Ruby 2.3 isn't stable anyway. Package-Manager: portage-2.2.27
Pacho Ramos · gentoo
net-libs/webkit-gtk: Version bump
Package-Manager: portage-2.2.27
Pacho Ramos · gentoo
net-libs/webkit-gtk: ruby19 was removed
Package-Manager: portage-2.2.26
Pacho Ramos · gentoo
net-libs/webkit-gtk: ia64 keyword, bug #566270 by Émeric Maschino
Package-Manager: portage-2.2.26
Pacho Ramos · gentoo
net-libs/webkit-gtk: Drop old
Package-Manager: portage-2.2.24
Pacho Ramos · gentoo
net-libs/webkit-gtk: Add a comment to remember where to find dependencies updates
Package-Manager: portage-2.2.24
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/zpuskas/kicad-doc-4.0.0-rc1'
Pull request: https://github.com/gentoo/gentoo/pull/403
Gilles Dartiguelongue · gentoo
net-libs/webkit-gtk: enhance ebuild
Raise dependency on gcc per build system information. Make use of toolchain-func to detect gold linker. Make gtk+:2 optional as it is only needed for netspace plugin API. Add missing dependency for properly switching on MPEG-TS support with gstreamer. Add support for quartz backend that has been added in 2.10 series (untested though). Package-Manager: portage-2.2.25
Pacho Ramos · gentoo
net-libs/webkit-gtk: hyphen is not keyworded on ia64 and alpha
Package-Manager: portage-2.2.24
Pacho Ramos · gentoo
net-libs/webkit-gtk: dev-libs/hyphen needed as DEPEND (#565872 by Randy Tupas)
Package-Manager: portage-2.2.24
Pacho Ramos · gentoo
net-libs/webkit-gtk: Drop old
Package-Manager: portage-2.2.24
Pacho Ramos · gentoo
net-libs/webkit-gtk: Version bump
Package-Manager: portage-2.2.24
Pacho Ramos · gentoo
net-libs/webkit-gtk: Fix alpha, bug #564352 by Brian Parkhurst and Alexander Tsoy
Package-Manager: portage-2.2.23
Pacho Ramos · gentoo
net-libs/webkit-gtk: Fix ia64, bug #555504 by Émeric Maschino
Package-Manager: portage-2.2.23
Pacho Ramos · gentoo
net-libs/webkit-gtk: Fix ia64, bug #555504 by Émeric Maschino
Package-Manager: portage-2.2.23
Alexandre Rostovtsev · gentoo
net-libs/webkit-gtk: cmake syntax is -DRUBY_EXECUTABLE, not RUBY
Package-Manager: portage-2.2.20.1
Agostino Sarubbo · gentoo
net-libs/webkit-gtk: x86 stable wrt bug #551826
Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="x86"
Mikle Kolyada · gentoo
net-libs/webkit-gtk: amd64 stable wrt bug #551826
Package-Manager: portage-2.2.20.1 RepoMan-Options: --ignore-arches
Pacho Ramos · gentoo
net-libs/webkit-gtk: Drop old
Package-Manager: portage-2.2.20.1
Pacho Ramos · gentoo
net-libs/webkit-gtk: Move again to ~ppc64 as upstream only cares about amd64/x86/>=arm7
Package-Manager: portage-2.2.20.1
Alexandre Rostovtsev · gentoo
net-libs/webkit-gtk: fix build with -j1
Reported-by: dolphinling Gentoo-Bug: 556680 Upstream-Bug-url: https://bugs.webkit.org/show_bug.cgi?id=148379 Package-Manager: portage-2.2.20.1
Jeroen Roovers · gentoo
net-libs/webkit-gtk: Stable for PPC64 (bug #547680).
Package-Manager: portage-2.2.20.1
Alexandre Rostovtsev · gentoo
net-libs/webkit-gtk: pass correct cmake flags when USE=gles2
Thanks-to: Gary E. Miller Thanks-to: Kamen Dokov Tahnks-to: Karl-Johan Karlsson Gentoo-Bug: 554096 Package-Manager: portage-2.2.20.1
Alexandre Rostovtsev · gentoo
net-libs/webkit-gtk: missing dependency
Thanks-to: brutester Gentoo-Bug: 554096 Package-Manager: portage-2.2.20.1
Alexandre Rostovtsev · gentoo
net-libs/webkit-gtk: add 2.8.5
Tests temporarily restricted since they fail to build. Gentoo-Bug: 556614 Package-Manager: portage-2.2.20.1
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed