net-mail / hyperkitty

A web interface to access GNU Mailman v3 archives

Official package sites : https://www.list.org ·

v1.3.3 :: 0 :: gentoo (Masked by set 5913)

Modified
License
GPL-3+
Keywords
~amd64
USE flags
test

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

python3_8
Build with Python 3.8

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / sassc : A libsass command line driver

dev-python / django : High-level Python web framework

dev-python / django-compressor : Compresses linked and inline JavaScript or CSS into single cached files

dev-python / django-extensions : A collection of custom extensions for the Django Framework

dev-python / django-gravatar2 : Essential Gravatar support for Django

dev-python / django-haystack : Pluggable search for Django

dev-python / django-q : A multiprocessing distributed task queue for Django

dev-python / djangorestframework : Web APIs with django made easy

dev-python / flufl-lock : NFS-safe file locking with timeouts for POSIX systems

dev-python / networkx : Python tools to manipulate graphs and complex networks

dev-python / python-dateutil : Extensions to the standard Python datetime module

dev-python / pytz : World timezone definitions for Python

dev-python / robot-detection : Module to detect if a given HTTP User Agent is a web crawler

dev-python / whoosh : Fast, pure-Python full text indexing, search and spell checking library

net-mail / django-mailman3 : Django-based interfaces interacting with Mailman 3

net-mail / mailmanclient : Python bindings for the GNU Mailman 3 REST API

net-mail / mailman-meta : Meta ebuild for GNU Mailman 3

792276
net-mail/hyperkitty: Possible private archive disclosure during migration (CVE-2021-33038)
832249
net-mail/hyperkitty needs porting to py3.9+
836724
net-mail/hyperkitty-1.3.3 does not enable tests

5913
Michał Górny
Mailman along with a bunch of dependencies that are of bad quality. At the very least, the Mailman packages need a dedicated maintainer. Their Python dependencies can be maintained by the Python team if someone takes care of getting the tests working. Removal on 2022-06-05. Bug #842888.
  • dev-python/aiosmtpd
  • dev-python/django-compressor
  • dev-python/django-extensions
  • dev-python/django-gravatar2
  • dev-python/django-haystack
  • dev-python/django-picklefield
  • dev-python/django-q
  • dev-python/falcon
  • dev-python/flufl-testing
  • net-mail/django-mailman3
  • net-mail/hyperkitty
  • net-mail/mailman
  • net-mail/mailman-meta
  • net-mail/mailmanclient
  • net-mail/postorius
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
Rename dev-python/{beautifulsoup → beautifulsoup4}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove obsolete values from PYTHON_COMPAT
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Hanno Böck · gentoo
net-mail/hyperkitty: Missing deps whoosh and sassc
Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1
Repository mirror & CI · gentoo
Merge updates from master
Hanno Böck · gentoo
net-mail/hyperkitty: Add missing dependency isort
Closes: https://bugs.gentoo.org/746035 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1
Repository mirror & CI · gentoo
Merge updates from master
Hanno Böck · gentoo
net-mail/hyperkitty: Initial commit.
Mail archiver for mailman 3. Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1