net-voip / captagent

100% Open-Source Packet Capture Agent for HEP

Official package sites : https://github.com/sipcapture/captagent · https://sipcapture.org/ ·

v6.3.1-r1 :: 0 :: gentoo (Masked by set 6311)

Modified
License
GPL-3+
Keywords
~amd64 ~x86
USE flags
ipv6 mysql pcre redis ssl

General

ipv6
Add support for IP version 6
mysql
Add mySQL Database support
pcre
Add support for Perl Compatible Regular Expressions
redis
Enable redis support
ssl
Add support for SSL/TLS connections (Secure Socket Layer / Transport Layer Security)

dev-db / mysql-connector-c : C client library for MariaDB/MySQL

dev-db / redis : A persistent caching system, key-value, and data structures database

dev-libs / json-c : A JSON implementation in C

dev-libs / libpcre : Perl-compatible regular expression library

dev-libs / libuv : Cross-platform asychronous I/O

dev-libs / openssl : Robust, full-featured Open Source Toolkit for the Transport Layer Security (TLS)

net-libs / libpcap : A system-independent library for user-level network packet capture

dev-db / mysql-connector-c : C client library for MariaDB/MySQL

dev-db / redis : A persistent caching system, key-value, and data structures database

dev-libs / json-c : A JSON implementation in C

dev-libs / libpcre : Perl-compatible regular expression library

dev-libs / libuv : Cross-platform asychronous I/O

dev-libs / openssl : Robust, full-featured Open Source Toolkit for the Transport Layer Security (TLS)

net-libs / libpcap : A system-independent library for user-level network packet capture

870910
net-voip/captagent-6.3.1-r1 - socket_pcap.c: error: incompatible integer to pointer conversion passing
877731
net-voip/captagent-6.3.1-r1 fails to compile (lto): configure: error: captagent requires but cannot find libfl
884815
net-voip/captagent-6.3.1-r1 - configure: error: bison not found. Please install bison
885845
last-rite of net-voip/captagent

6311
Jaco Kroon
Multiple open bugs (bug #870910, bug #877731, bug #884815), only one of which is trivial to solve. With more and more SIP traffic using TLS rather than plaintext UDP or TCP this is fast becomming less and less useful. You should rather use asterisk's res_hep which can also report encrypted SIP and RTP to any HEP compatible reporting tool (including Homer). I'm no longer using this and don't recommend it's use, if you want this to be unmasked again, please contact me so that we can figure out how to approach maintenance thereof. Last-rites bug #885845. Removal on 2023-01-31.
  • net-voip/captagent
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-voip/captagent: fix patch name
Closes: https://bugs.gentoo.org/831582 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jaco Kroon · gentoo
net-voip/captagent: revision bump to fix clang compile
Upstream: https://github.com/sipcapture/captagent/pull/245 Not expecting a new release soon. Closes: https://bugs.gentoo.org/831391 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/23880 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
net-voip/captagent: add subslot binder to openssl
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Joonas Niilola · gentoo
net-voip/captagent: update DESCRIPTION, don't replicate PN
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Jaco Kroon · gentoo
net-voip/captagent: New Package. Version 6.3.1.
CaptAgent: 100% Open-Source Packet Capture Agent for HEP autoconf patch from upstream (in response to issue report). gcc10 patches pending on PR. Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/20854 Signed-off-by: Joonas Niilola <juippis@gentoo.org>