sci-libs / med

A library to store and exchange meshed data or computation results

Official package sites : https://www.salome-platform.org/user-section/about/med ·

v4.0.0-r2 :: 0 :: gentoo

Modified
License
LGPL-3
Keywords
~amd64 ~x86
USE flags
doc fortran mpi python test

v4.0.0-r1 :: 0 :: gentoo

Modified
License
LGPL-3
Keywords
~amd64 ~x86
USE flags
doc fortran hdf5-16-api python test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
fortran
Add support for fortran
hdf5-16-api
Use -DH5_USE_16_API to build the package against old 1.6 API of HDF5
mpi
Add MPI (Message Passing Interface) layer to the apps that support it
python
Add optional support/bindings for the Python language
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_single_target

python3_5
Build for Python 3.5 only
python3_6
Build for Python 3.6 only
python3_7
Build for Python 3.7 only

python_targets

python3_5
Build with Python 3.5
python3_6
Build with Python 3.6
python3_7
Build with Python 3.7

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-lang / tk : Tk Widget Set

sci-libs / hdf5 : General purpose library and file format for storing scientific data

virtual / fortran : Virtual for Fortran Compiler

virtual / mpi : Virtual for Message Passing Interface (MPI) v2.0 implementation

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-lang / tk : Tk Widget Set

sci-libs / hdf5 : General purpose library and file format for storing scientific data

virtual / fortran : Virtual for Fortran Compiler

virtual / mpi : Virtual for Message Passing Interface (MPI) v2.0 implementation

sci-libs / gmsh : A three-dimensional finite element mesh generator

692438
sci-libs/med-4.0.0 : checking for Fortran 77 name-mangling scheme... configure: error: in /.../med-4.0.0 :
Repository mirror & CI · gentoo
Merge updates from master
Bernd Waibel · gentoo
sci-libs/med: switch to cmake based build
The patch moves back to the cmake based build used in sci-libs/libmed. The issues with sci-libs/gmsh not building with cmake built med have been resolved. See https://bugs.gentoo.org/693146 comments 19-22 Closes: https://bugs.gentoo.org/694468 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12930 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthias Maier · gentoo
sci-libs/med: rename use flag
Bug: https://bugs.gentoo.org/693146 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthias Maier · gentoo
sci-libs/med: immediately switch to new variant
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Bernd Waibel · gentoo
sci-libs/med: merge libmed into med
* Merge sci-libs/libmed into sci-libs/med, to resolve redundancy. * Changed to use autotools instead of cmake, as sci-libs/gmsh does not build against the cmake built variant. * Remove mpi USE flag, as there's no option to disable mpi support when using autotools to build the package. Closes: https://bugs.gentoo.org/693146 Package-Manager: Portage-2.3.74, Repoman-2.3.17 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthias Maier · gentoo
sci-libs/med: package migration from ::science overlay
* version bump * new upsteam website and repo * EAPI=7 * fixup installation Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>